pockestrap

Web Programmer's memo

急にgemにroot権限を求められた

~/.gemrcgem: --no-ri --no-rdoc --user-install を追記したところ、gemのインストールにroot権限が必要になってしまった。

/etc/gemrc を見てみると、gem: --user-install の記述がある。これがあるなら ~/.gem/ 下にgemがインストールされるはずだ。
つまり、 ~/.gemrc を設定すると /etc/gemrc の設定は読まれなくなるのではないか。
そう思い、~/.gemrc--user-install を追記したら無事ユーザー権限でgemをインストールすることが出来た。